We are experiencing issues with displaying banner images in some stores.

Incident Report for Acendy

Resolved

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 17:07 CEST

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 17:07 CEST

Investigating

We are currently investigating the issue.
Posted Mar 31, 2025 - 14:41 CEST
This incident affected: Webshop.